difficulty using MoveSCU

All other questions regarding DCMTK

Moderator: Moderator Team

Post Reply
Posts: 7
Joined: Fri, 2007-05-04, 16:04

difficulty using MoveSCU

#1 Post by seabhcan » Fri, 2007-05-11, 14:05


(First, Thank you very much for your excellent DICOM code!)

I want to use MoveSCU to copy some DICOM files from another computer. (I have the new version of MoveSCU which has the --key bug fixed)

I run the command:
movescu -v -P -k 0008, 0052="PATIENT" -k 0010,0020="0526173" IP_Address 5678
This fails with the output:
Requesting Association
Association Accepted (Max Send PDV: 16372)
Sending query
Move SCU RQ: MsgID 1

# Dicom-Data-Set
# Used TransferSyntax: UnknownTransferSyntax
(0008,0052) CS [PATIENT] # 8, 1 QueryRetrieveLevel
(0010,0020) LO [0526173] # 8, 1 PatientID
C-Move RSP: MsgID: 1 [Status=Failed: UnableToProcess]
AffectedSOPClassUID: =MOVEPatientRootQueryRetrieveInformationModel
Data Set: Not Present
NumberOfRemainingSubOperations: 0
NumberOfCompletedSubOperations: 0
NumberOfFailedSubOperations: 0
NumberOfWarningSubOperations: 0
Releasing Association
The DICOM server outputs:
C-Move Destination "MOVESCU "
Number of images to send: 480
Host "MOVESCU" did not accept the connection
FindSCU and EchoSCU work perfectly with this DICOM server.

I've also tried specifying the port as 9876 but this doesn't help.

What am I doing wrong??



UPDATE: problem solved. It was a problem on the other machine. It doesn't like sending on a different port to the receive.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest