Findscu not working in debian Etch

All other questions regarding DCMTK

Moderator: Moderator Team

Post Reply
Posts: 3
Joined: Thu, 2006-01-12, 02:01

Findscu not working in debian Etch

#1 Post by ksitu » Thu, 2007-07-19, 00:58

The dcmtk I am now using in debian Etch is version "dcmtk: findscu v3.5.4 2005-12-20", which I am problem with findscu.

I got this error message: "error: bad key format or dictionary name not found in dictionary: 0010,0020=004099999"

The command line I used is this:
findscu -S -k 0010,0020=004099999 -aet TESTAET -aec MYMSTERAEC 5000 ./CFindQuery.dcm

and I also tried this:
findscu -P -k PatientID=004099999 -aet TESTAET -aec MYMSTERAEC 5000 ./CFindQuery.dcm

would also give the same error.

Any help is much appreciated. Thanks


Michael Onken
DCMTK Developer
Posts: 1815
Joined: Fri, 2004-11-05, 13:47
Location: Oldenburg, Germany

#2 Post by Michael Onken » Thu, 2007-07-19, 08:41


this is an alltime favourite bug in 3.5.4. Please refer to FAQ #43, which also contains a link to a fixed version.


Jörg Riesmeier
Posts: 2217
Joined: Fri, 2004-10-29, 21:38
Location: Oldenburg, Germany

#3 Post by Jörg Riesmeier » Thu, 2007-07-19, 09:40

There's also a Debian bug report.

DCMTK Tester
Posts: 13
Joined: Thu, 2004-11-25, 15:59

#4 Post by jsalk » Tue, 2007-07-24, 07:18

I have already uploaded a fixed Debian package version to
ftp-master. ... 3204Z.html

However, on s390 the package fails to build from source with an
internal compiler error while it builds successfully on a number
of other architectures:

The full build log for s390 can be found at: ... 1185227212

This is most probably a bug in the toolchain on s390 which needs
to be resolved before the updated package can enter testing.

Best regards - Juergen

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest