[Movescu - SOLVED] - can't retrieve picture.

All other questions regarding DCMTK

Moderator: Moderator Team

Post Reply
Posts: 5
Joined: Wed, 2005-11-02, 16:13

[Movescu - SOLVED] - can't retrieve picture.

#1 Post by dake » Wed, 2005-11-02, 16:21

Solved - see my answer below for those interested...


I'm quite new to DICOM and DCMTK in general, I'm trying to understand how queries do work.

I set up a ConQuest server listening on port 5678 (version 1.4.9a - I also tried with 1.4.8 -). Echoscu is working, I could also send some .dcm onto the server.

Now I'm trying to retrieve some files from the database, I have a dcm whose patient ID is ACN000004 :
movescu -k "0010,0020=ACN000004" 5678
Here is the answer from Conquest, it tells one picture is going to be sent but MOVESCU refuses the connection :
[CONQUESTSRV1] UPACS THREAD 14: STARTED AT: Wed Nov 02 16:16:20 2005
[CONQUESTSRV1] Calling Application Title : "MOVESCU "
[CONQUESTSRV1] Called Application Title : "ANY-SCP "
[CONQUESTSRV1] Application Context : "1.2.840.10008."
[CONQUESTSRV1] Presentation Context 0 "1.2.840.10008."
[CONQUESTSRV1] Presentation Context 1 "1.2.840.10008."
[CONQUESTSRV1] C-Move Destination: "MOVESCU "
[CONQUESTSRV1] Number of images to send: 1
[CONQUESTSRV1] Host 'MOVESCU' did not accept the connection
[CONQUESTSRV1] C-Move (PatientRoot)
[CONQUESTSRV1] UPACS THREAD 14: ENDED AT: Wed Nov 02 16:16:26 2005

Ok, the problem was related to ConQuest. Here's my own answer :) - In the "known DICOM providers", one has to add a line such as :

Code: Select all

MOVESCU         104        un
Then create this query :

Code: Select all

(0008,0052) CS [PATIENT]     # QueryRetrieveLevel
(0010,0020) LO [*]      # PatientID
convert with dump2dcm and then :

Code: Select all

movescu localhost 5678 query.dcm

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest