Error while using dcmtk printscu.

Questions regarding the "Consistent Presentation of Images" test suite in the IHE MESA toolkit

Moderator: Moderator Team

Post Reply
Message
Author
jeanledesma10
Posts: 3
Joined: Mon, 2009-03-09, 12:02

Error while using dcmtk printscu.

#1 Post by jeanledesma10 » Mon, 2009-03-09, 12:14

Hello, I'm doing some tests to validate a Print server with Presentation LUTs.

I've downloaded the printscp_testcases for MESA and I try dcmprscu.exe in a shell:
printscp_testcases > printscp_test.bat all_paper

All the tests I try, pass the association, the LUT create request, film session create request and film box create request and then blocks.
In the result logs, the last line is always:

"spooler: unable to locate image file in database.
error: spooling of file 'printjobs\'xxx'.dcm' failed."

Can you help me with that? do I have to insert manually the images in the database? And if that's the case, in which table?

Thank you.

Jörg Riesmeier
ICSMED DICOM Services
ICSMED DICOM Services
Posts: 2217
Joined: Fri, 2004-10-29, 21:38
Location: Oldenburg, Germany

#2 Post by Jörg Riesmeier » Mon, 2009-03-09, 12:25

From the documentation (printscp_testplan.doc):
- printscp_test reindex causes the operating system dependent index file required by the Print SCU to be created. This should be performed once before the test cases are sent to the printer.
Maybe, it's that simple ...

jeanledesma10
Posts: 3
Joined: Mon, 2009-03-09, 12:02

#3 Post by jeanledesma10 » Mon, 2009-03-09, 13:50

Thank you very much. It works.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest