HAVE_SSL_CTX_GET0_PARAM not defined when it should be.

Compilation and installation of DCMTK

Moderator: Moderator Team

Post Reply
Message
Author
DraconPern
Posts: 9
Joined: Thu, 2006-03-02, 08:46

HAVE_SSL_CTX_GET0_PARAM not defined when it should be.

#1 Post by DraconPern » Sun, 2019-11-17, 09:56

the autodetected value HAVE_SSL_CTX_GET0_PARAM in osconfig.h should be defined when using openssl 1.1.1 since ssl.h does define SSL_CTX_get0_param. I think the call to CHECK_FUNCTIONWITHHEADER_EXISTS may be broken, either the function or the call parameters?

Marco Eichelberg
OFFIS DICOM Team
OFFIS DICOM Team
Posts: 1280
Joined: Tue, 2004-11-02, 17:22
Location: Oldenburg, Germany
Contact:

Re: HAVE_SSL_CTX_GET0_PARAM not defined when it should be.

#2 Post by Marco Eichelberg » Mon, 2019-11-18, 11:58

HAVE_SSL_CTX_GET0_PARAM should indeed be defined when using OpenSSL 1.1.1.

Can you please check the content of CMakeFiles/CMakeOutput.log in your build folder?
When you search for "SSL_CTX" in this log file, you should find a log similar to this one:

Code: Select all

Determining if the SSL_CTX_get0_param exist passed with the following output:
Change Dir: /home/builddir/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/make" "cmTC_1d0dd/fast"
/usr/bin/make -f CMakeFiles/cmTC_1d0dd.dir/build.make CMakeFiles/cmTC_1d0dd.dir/build
make[1]: Entering directory '/export/home/builddir/CMakeFiles/CMakeTmp'
Building CXX object CMakeFiles/cmTC_1d0dd.dir/CheckSymbolExists.cxx.o
/usr/bin/c++ [...] -O3 -DNDEBUG   -o CMakeFiles/cmTC_1d0dd.dir/CheckSymbolExists.cxx.o -c /home/builddir/CMakeTmp/CheckSymbolExists.cxx
Linking CXX executable cmTC_1d0dd
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_1d0dd.dir/link.txt --verbose=1
/usr/bin/c++ [...] -O3 -DNDEBUG    CMakeFiles/cmTC_1d0dd.dir/CheckSymbolExists.cxx.o  -o cmTC_1d0dd
make[1]: Leaving directory '/export/home/builddir/CMakeFiles/CMakeTmp'

File /home/builddir/CMakeTmp/CheckSymbolExists.ccc:
/* */
#include <openssl/ssl.h>

int main()
{
SSL_CTX_get0_param;return 0;
}
In your case, a compile error message should be shown, and this would be important to know to identify the problem.
Is it perhaps possible that you have multiple versions of OpenSSL installed and that the include files included by <openssl/ssl.h> are taken from the wrong directory?

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest