Unsatisfied link error regarding jInterface.dll

All other questions regarding DICOMscope

Moderator: Moderator Team

Post Reply
Message
Author
w.schoech
Posts: 2
Joined: Wed, 2008-02-20, 15:22

Unsatisfied link error regarding jInterface.dll

#1 Post by w.schoech » Wed, 2008-02-20, 20:38

Hello all,

I am a simple user of DICOMscope 3.51 under Windows XP SP 2. Everything worked just fine until recently, when the program didn't start any more via double-click. Running from the command line I receive error messages like this:

C:\Programme\DICOMscope351> java -jar DICOMscope.jar
starting DICOMscope
please wait...
Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Programme\DICOMscope351\jInterface.dll: Das Betriebssystem kann %1 nicht ausführen
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at main.MainContext.<clinit>(MainContext.java:58)
at DICOMscope.main(DICOMscope.java:92)

Has anyone else experienced this behaviour? I have updated the Java VM recently to 1.6.0_03, 1.6.0_02 delivers the same result. Is it helpful to try an older version of the JVM?

Again, I didn't compile anything but used the setup bundle for Windows. A re-install of DICOMscope didn't help either (not that I expected it to).

Any answer will be appreciated! Thanks and best regards,

Winfried

Jörg Riesmeier
ICSMED DICOM Services
ICSMED DICOM Services
Posts: 2217
Joined: Fri, 2004-10-29, 21:38
Location: Oldenburg, Germany

#2 Post by Jörg Riesmeier » Fri, 2008-02-22, 09:58

Has anyone else experienced this behaviour? I have updated the Java VM recently to 1.6.0_03, 1.6.0_02 delivers the same result. Is it helpful to try an older version of the JVM?
You could also try to install DICOMscope 3.6.0 (binary only). This version works on my XP system with JRE 1.6 (1.6.0_03) without any problems. You can download it from http://www.dcmtk.org/download/dscope/dscope360/bin/ .

w.schoech
Posts: 2
Joined: Wed, 2008-02-20, 15:22

#3 Post by w.schoech » Mon, 2008-03-17, 11:58

Unfortunately, DICOMScope 3.6.0 (binary version) shows the same behaviour on my system, though with a slightly different stack trace due to its binary nature:

Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Programme\DICOMscope360\jInterface.dll: Das Betriebssystem kann %1 nicht ausführen
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at main.MainContext.<clinit>(Unknown Source)
at dicomscope.DICOMscope.main(Unknown Source)

Any other ideas? I'm quite desperate, as DICOMScope seems to be *the* tool to choose for my purposes...

Best regards, Winfried

Jörg Riesmeier
ICSMED DICOM Services
ICSMED DICOM Services
Posts: 2217
Joined: Fri, 2004-10-29, 21:38
Location: Oldenburg, Germany

#4 Post by Jörg Riesmeier » Wed, 2008-03-26, 15:50

Unfortunately, I have no idea since it works on my Windows XP system. Btw, I just found out that - in the meantime - I'm using JRE 1.6.0_05-b13 :-)

Marco Eichelberg
OFFIS DICOM Team
OFFIS DICOM Team
Posts: 1280
Joined: Tue, 2004-11-02, 17:22
Location: Oldenburg, Germany
Contact:

#5 Post by Marco Eichelberg » Thu, 2008-04-03, 08:43

The internal Windows error code that produces this message on a German version of Windows NT, 2000 or XP is ERROR_INVALID_ORDINAL. My best guess is that jInterface.dll is damaged, wrong version or there is some access right or system policy in place that prevents Java from loading the DLL.

santosh
Posts: 61
Joined: Tue, 2007-07-31, 09:27
Location: Bangalore (India)

#6 Post by santosh » Thu, 2009-01-22, 10:12

Hi,
If u have fixed this error, please let me know the solution as i am facing the same error.

Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\WINDOWS\system32\jInterface.dll: The operating system cannot run %1
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at main.MainContext.<clinit>(Unknown Source)
at dicomscope.DICOMscope.main(Unknown Source)
Santosh S B

oldold
Posts: 1
Joined: Tue, 2009-06-16, 09:48

#7 Post by oldold » Tue, 2009-06-16, 15:40

I have the same problem after I installed openssl, and after I delete theirs dll file from system32 fold, the dscope runs well. Hope info any help other poeples

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest