Problem using storescu

All other questions regarding DCMTK

Moderator: Moderator Team

Post Reply
Posts: 3
Joined: Fri, 2010-08-06, 14:31
Location: Magog

Problem using storescu

#1 Post by martel » Fri, 2010-08-06, 14:50

I am trying to push images, but apparentlu I got it wrong...

My images are JPEG baseline, and I want to send them that way.

I tried:
storescu -v --propose-jpeg8 toto 1234 image

And I get:

Requesting Association
Association Accepted (Max Send PDV: 16372)
Sending file: us
Transfer: JPEGBaseline -> LittleEndianExplicit
Store SCU RQ: MsgID 1, (US)
XMIT:DIMSE Warning: (STORESCU,ANY-SCP): sendMessage: unable to convert dataset
from 'JPEG Baseline' transfer syntax to 'LittleEndianExplicit'.

storescu: Store Failed, file: us:
1200a2 DIMSE Failed to send message
storescu: SCU Failed:
1200a2 DIMSE Failed to send message
Aborting Association

I tried to send to either storescp or conquest. I can sent uncompressed images O.K., I just can't make it work for the compressed images...

What am I doing wrong?


Jörg Riesmeier
Posts: 2217
Joined: Fri, 2004-10-29, 21:38
Location: Oldenburg, Germany

#2 Post by Jörg Riesmeier » Fri, 2010-08-06, 15:04

The storage SCP does not accept / support the compressed transfer syntax, and storescu is not able to decompress the image.

Depending on whether you want to transmit the images with the encapsulated transfer syntax (i.e. compressed) or not (i.e. uncompressed), you either need to change the configuration of the SCU or the one of the SCP.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest